Пошук в Ексель – комбінація клавіш, яка формула відповідає, як шукати потрібного слова, фрази, одному або декільком значенням в Excel

Excel – програма для роботи з електронними таблицями. Документи у цій програмі можуть бути об’ємними з безліччю листів. Тому для зручного пошуку потрібного слова, фрази, таблиці, ячейки або формули існує спеціальний інструмент, користуватися яким нескладно.

Пошук в Excel

Самий простий і швидкий спосіб шукати слова, фрази, формули і т. д у документі це використовувати комбінацію клавіш Ctrl і F одночасно. З’явиться наступне вікно.

Тут знадобиться ввести шукане слово, фразу і т. д.

Другий варіант пошуку в Excel — на головній сторінці натиснути кнопку «Знайти і виділити». Вибираємо «Знайти», вводимо потрібні символи і запускається пошук.

Програма почне шукати і виділить всі місця, де є шукане слово або фраза. Якщо документ дуже великий, то процес може зайняти деякий час.

Після, буде виданий список з адресами комірок, де є шукана комбінація. Клікнувши на потрібний рядок, курсор перенесе на потрібну клітинку.

В полі можна використовувати символи підстановки * і ?.

Зазвичай їх застосовують у таких ситуаціях:

  1. * — може бути використана для заміни букв. Наприклад, якщо ввести «к*т», то знайдуться всі слова, які починаються на букву «к» і закінчуються на «т», кіт, кіт і т. д. Зірочка замінює один символ, так і будь-яку кількість. Тобто в нашому прикладі знайдуться і слова кабінет, кабріолет і т. д.
  2. ? — такий знак підстановки замінює тільки одну букву. Наприклад, «до?т», вийдуть слова, які складаються з трьох літер «кіт», «кит».

Налаштування пошуку

Якщо необхідно встановити певні параметри, то у вікні необхідно натиснути «Параметри».

Тут можна задати наступні параметри:

  • у рядку «Шукати» можна обмежити пошук тільки листом;
  • у рядку «Переглядати» можна вибрати варіант перегляду по рядках або по стовпцях;
  • рядок «Область» дозволяє вибрати потрібні символи: формула, або значення;
  • відзначивши галочкою «Враховувати регістр» проводиться знаходження шуканої комбінації з урахуванням регістру;
  • якщо необхідно побачити клітинку, яка містить тільки задані символи, потрібно відзначити «Клітинка цілком»;
  • у вкладці «Формат» можна вибрати потрібне форматування.

Встановлення ступеня у Word

Натискаючи кнопку «Замінити», можна відразу замінити знайдене на зазначені значення.

У рядку «Знайти» потрібно ввести шукану комбінацію значень, а в рядку «Замінити» ті символи, на які слід замінити знайдені.

Пошук за вказаною інтервалу

Знаходження за вказаною інтервалу може знадобитися в тому випадку, якщо таблиця дуже велика, і при звичайному виявленні знаходиться занадто велику кількість значень.

Цим способом обмежується діапазон для знаходження комбінації.

Порядок дій:

  1. Виділяємо діапазон, для якого потрібно визначити значення.

  2. Запускаємо пошук будь-яким способом, описаним вище. Відмінність лише в тому, що спочатку для роботи буде виділено певний діапазон.

Пошук по декільком умовам

Знаходження за кількома критеріями здійснюється за допомогою функції пошуку ВВР, яка до певної міри відповідає пошуку по документу. ВВР розшифровується як вертикальний перегляд. Функція шукає значення за вказаним у запиті критеріям. У простому виявленні можна обробити відразу кілька умов. ВВР допомагає розширити функції для знаходження.

Наведемо приклад пошуку кількох значень. В таблиці вказана різна ціна різного граніту. Необхідно з допомогою функції ВВР визначити ціну граніту 7.

Складемо таблицю.

Формули в комірку Е4, але можна використати будь-яку іншу. Потім дотримуємося алгоритму:

  1. У комірці ставимо знак рівності і прописуємо функцію: «=ВПР(».
  2. Аргумент 1 це Гранит7. Пишемо «ВВР(«Гранит7»».
  3. Аргумент 2 – це комірки А4:А20. Формула виходить такий: «ВВР(«Гранит7»; А4:А20;».
  4. Аргумент 3, цифра 2, т. к. шукаємо значення у другому стовпці. «ВВР(«Гранит7»; А4:А20;2».
  5. Аргумент 4, дає зрозуміти функції, яке значення потрібно шукати, точне або приблизне. Воно може бути TRUE або FALSE. ІСТИНА – приблизно співпалі значення, а БРЕХНЯ – точні. Ми шукаємо точні. Виглядає запис так: «ВВР(«Гранит7»; А4:А20;2;ХИБНІСТЬ» або «=ВПР(A10;A4:B20;2;БРЕХНЯ)».
  6. Клікаємо по Enter і отримуємо шукане.

Використовуємо функцію «Якщо» в Excel

Аналогічним способом можна додавати умови в більш складних таблицях.

Наприклад, додамо в таблицю стовпець з місяцем. Спробуємо побачити в якому місяці Гранит17 варто 1016.

Складаємо формулу, додаючи нові значення. Аргументом 3 буде цифра 3.

Натискаємо enter і отримуємо місяць «травень».

Функція пошук в Excel

Також для виявлення можна використовувати функції ПОШУК і ЗНАЙТИ.

Спочатку розглянемо функції ЗНАЙТИ. З її допомогою можна автоматично визначити позицію в текстовому рядку, вона розрізняє великі та малі літери.

Приклад: знайдемо положення літери «а» в слові Гранит6. Введемо формулу =ЗНАЙТИ(«а»;A9;3) і отримаємо 3, тобто «а» третя буква.

Тепер розглянемо функцію ПОШУК. У даній формулі можна використовувати символи символи (? — один, * — кілька). Наприклад, знайдемо в тій же клітинці положення цифри 6. Введемо формулу =ПОШУК(«6»;A9), отримуємо 8.